You cannot select more than 25 topics
Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
19 lines
590 B
Nix
19 lines
590 B
Nix
let
|
|
# iohk-nix can be overridden for debugging purposes by setting
|
|
# NIX_PATH=iohk_nix=/path/to/iohk-nix
|
|
iohkNix = import (
|
|
let try = builtins.tryEval <iohk_nix>;
|
|
in if try.success
|
|
then builtins.trace "using host <iohk_nix>" try.value
|
|
else
|
|
let
|
|
spec = builtins.fromJSON (builtins.readFile ./nix/iohk-nix-src.json);
|
|
in builtins.fetchTarball {
|
|
url = "${spec.url}/archive/${spec.rev}.tar.gz";
|
|
inherit (spec) sha256;
|
|
}) {};
|
|
|
|
pkgs = iohkNix.pkgs;
|
|
lib = pkgs.lib;
|
|
in lib // { inherit iohkNix pkgs; inherit (iohkNix) nix-tools; }
|